Updated package failed to install (prescript abort)

Updated package failed to install (prescript abort)

We updated an existing application to a new version. When the device installs the update, the update fails and MobiControl dashboard reports that the package failed to install (prescript abort).

The package does not have any preinstall scripts so I'm not sure what's going on. Also if I revert back to the old version, everything is fine.


If I go into the device in MobiControl and force the package reinstallation, it installs fine on the device, but still says Failed to install (prescript abort).


Any ideas?

7 Answers

Order By:   Standard | Newest | Votes
Marcus Breitenthaler | posted this 17 August 2021

Hi Kevin,

 

could it be that you execute an Script in the "Pre-install" Script what should be switched into the "Post-Install" Script. when the package is on the Device what you try to execute.

I think when you reinstall the package the needed Data is allready on the Device ?

  • 0
  • 0
Kevin Rice | posted this 06 August 2021

Marcus,


Appreciate the help here. I don't have anything in a pre or post install script. I would agree with your call on the program running causing the issue, but we're having the issue even if we do a hard reboot the program is still failing to install.

  • 0
  • 0
Marcus Breitenthaler | posted this 06 August 2021

Hi Kevin,

 

can you show what you are doing in the Script.

My experience is that when the Application is Runnig it made Problems with updating the runnig application on WM /CE.

  • 0
  • 0
Kevin Rice | posted this 05 August 2021

Appreciate your willingness to help!

  • 0
  • 0
Matt Dermody | posted this 05 August 2021

Ah, completely missed that. It's rare to see net new configuration changes or updates being made on Windows CE devices these days! I'm afraid I can't be much help in this case. 

  • 0
  • 0
Kevin Rice | posted this 05 August 2021

Well it's not an Android - it's Windows CE. It is a higher version increment. 

  • 0
  • 0
Matt Dermody | posted this 05 August 2021

To perform a clean direct upgrade of an APK to a new version via Package you need to ensure the following:

- The APK version must be incremented to a higher version from the previous. It cannot be the same or lower

- The APK must be signed with the same signature as the original APK

- The bundle ID (com.x.y) must remain the same

- The existing Package for the existing APK has to be modified with the new APK and also incremented from a version perspective.

 

Were all of these criteria met?

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback