W10 modern certificate enrollment : missing user agent

W10 modern certificate enrollment : missing user agent



I'm trying to enroll W10 tablets with certificates enrollment.

I'm familiar with the process as I did it several times already, but this time, it won't get through.

I did everything by the book, generated all the needed certificates, prepared the mobicontrol server, and generated the WICD package for the tablets, but when looking at the DSE log, I see this :


[2019-06-03 13:30:32.171] ERROR [] (90): Enrollment failure: Client Info is missing User Agent.
[2019-06-03 13:30:32.171] ERROR [] (90):

* Exception: The operation has failed. *
[InvalidOperationException: Enrollment state is incorrect. Unable to determine the next enrollment step.]
at Soti.MobiControl.Server.Enrollment.Service.Internal.BasicEnrollmentModelExtensions.PopulateEnrollmentState(BasicEnrollmentModel model, EnrollmentState state, String serviceRoot)
at Soti.MobiControl.Server.Enrollment.Service.Internal.EnrolmentContentProvider.PopulateBasicModel(EnrollmentContext context, BasicEnrollmentModel model)
at Soti.MobiControl.Server.Enrollment.Service.Internal.EnrolmentContentProvider.GetErrorModel(EnrollmentContext context)
at Soti.MobiControl.Server.Enrollment.Service.Internal.EnrolmentContentProvider.<>c__DisplayClass18_0`2.<AddPage>b__1(EnrollmentContext context)
at Soti.MobiControl.Server.Enrollment.Service.Internal.EnrolmentContentProvider.GetResource(EnrollmentContext context)
at Soti.MobiControl.Server.Enrollment.Service.Internal.DeviceEnrollmentService.ProcessEnrollmentStateAndUserData(EnrollmentUserData userData, EnrollmentState enrollmentState)
at SyncInvokeEnroll(Object , Object[] , Object[] )
at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)


I checked the provisionning diagnostics provider event log on the device, everything looks fine except the provisioning failed at the end, so the device package looks fine (otherwise I have some more explicit messages).

The server is on SOTI Cloud, latest 14.3.3

Talks to someone ?

Thank you

2 Answers

Order By:   Standard | Newest | Votes
HNMOD@SOTI | posted this 24 June 2019

Hello Laurent,

In order to provide you with a solution to this i believe opening a case would be the best route to take.

You can open a new case using the link provided below:


You may also link to this post to provide the agent with more information:


Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Laurent, NACHBAUER | posted this 25 June 2019



Thanks for your answer, I already opened a case @ EU support, just forgot to update here.

Fact is, my problems were only related to one device, other devices from same model didn't have the issue.


At first the problematic device didn't show up on the console at all.

Then I reset the device, and it did show up on the console but remained desperately offline.

I then noticed that the agent didn't download/install.

Then after several hours, the agent installed and it worked. Funny thing is... I did nothing to make it work.


Anyway, as the production devices don't have the issue, I'll put that on the mysteries in the universe that remain to be solved.

  • 0
  • 0

Give us your feedback
Give us your feedback