Warning Invalid device software version (Device is not allowed to upgrade)

Warning Invalid device software version (Device is not allowed to upgrade)

Hi,

We’ve upgraded our main SOTI-Server to v14 right after the initial release.

Afterwards we had an issue upgrading our device agents because they were too old, thus we had to contact your support team.

 

After editing some tables in the database, and lowering the “min. required version” it was working fine and we could upgrade our Samsung device-agent’s.

 

However we still have some Getac devices that can’t be upgraded because the device agent is outdated thus we can't enrol any packages to them.

It’s also showing us the “yellow call sign” but after trying to upgrade we get the message Invalid device software version (Device is not allowed to upgrade)”

 

Which tables do I've to edit to get the trick done again ?

 

BR

Markus Rose

  • 09 February 2018
  • SOTI MobiControl
  • 3 Answers
  • 0 Upvote
  • 2 Followers
  • 383 Views
    • 3 Answers
    • 0 Upvote
    • 2 Followers

3 Answers

Order By:   Standard | Newest | Votes
Support Staff | posted this 09 February 2018

Hi Markus, 

 

What type of devices, and the OS version are you having these issue with?  

Try going to our site for device agents. I will include a link to this information below.

www.soti.net/OEM

Let us know if there is an agent for your version and device type and I will let you know next steps.

Regards,

 

  • 0
  • 0
Markus Rose | posted this 12 February 2018

Device:Getac Z710. 

OS Version: 4.1.1

Yes ,there is a new agent available. However, this does not help.

We can't upgrade them all manually(~45 tablets) and via Soti MobiControl,  we aren't able to start the upgrade. (not allowed)

Our customers are using these tablets in trucks (all over the world).

  • 0
  • 0
Support Staff | posted this 12 February 2018

 

Hi Markus, 

 

As long as there is an updated agent that can be applied to the device's we can perform an agent injection.  If not, we can once again manipulate your DB to accept the current agent as the most compatible.

 

However, as any adjustments made by anyone not authorized by Soti (Technicians) would void any warranties regarding your MobiControl Server, we can complete this DB manipulation for you instead .

 

Please select the link below to create a case and someone from our support department will reach out to you to discuss fixing this for you.  

 

http://www.soti.net/services/support/supportcase/

 

Regards, 

 

Soti Support

 

  • 0
  • 0
Feedback