Windows devices cannot connect to server

Windows devices cannot connect to server

Hi,

I have some issue with some Microsoft 10 tablet devices.

After installing the agent, the devices cannot connect to the MobiControl server. If I launch the agent on the device I can see that the agent is trying to connect but disconnect automatically 2 seconds after.

 

I think that I have found the log on our server but not sure about that, below are the logs, coumd someone help me with this?

 

2020-11-20 18:34:04,657 (0x000006d4) [DEBUG] Enter
2020-11-20 18:34:04,657 (0x000006d4) [ERROR] No Device found with Device Id: 026808483951-{8764d21d-78d0-11e8-b75b-806e6f6e6963}
2020-11-20 18:34:04,657 (0x000006d4) [DEBUG] [ 22] Comm.Client.4299: Send message: AckErrorMsg:{"Error":ServerDatabaseError,"ExtraCode":0},Message:{"TimeStamp":"11/20/2020 6:34:04 PM"}
2020-11-20 18:34:04,657 (0x000006d4) [ERROR] OnInstallStatus: Error 2 getting device info, connection 4299, device 026808483951-{8764d21d-78d0-11e8-b75b-806e6f6e6963}
2020-11-20 18:34:04,689 (0x00001180) [ERROR] <140> Comm.Client.4299: Connection with [::ffff:90.79.33.29]:50119 has been reset.
2020-11-20 18:34:05,485 (0x00000814) [INFO ] [ 24] PulseChecker enter: Send: True, Check: True, Memory: 129809120, Threads: 32767/999/44, Queue: 0, Workers: 4, at 3,737 Bps 0 Dps
2020-11-20 18:34:05,485 (0x00000814) [INFO ] [ 24] PulseChecker exit: Total: 8, Connected: 5, Busy: 0, Dropped: 0, Retried: 0, Threads: 32767/999/44, finished in 0.000 ms, at 3,737 Bps 0 Dps
2020-11-20 18:34:06,910 (0x0000124c) [INFO ] < 53> Comm.Client.4300: Accepted a new connection from [::ffff:90.79.33.29]:50303.
2020-11-20 18:34:06,988 (0x000013e4) [WARN ] < 29> Comm.Client.4300: Certificate validation failed. SSL Policy Error: RemoteCertificateChainErrors. Status: PartialChain.
2020-11-20 18:34:06,988 (0x000013e4) [INFO ] < 29> Comm.Client.4300: Client [::ffff:90.79.33.29]:50303 authenticated. Cipher: Aes256/256
2020-11-20 18:34:07,050 (0x0000124c) [DEBUG] < 53> Comm.Client.4300: Received message: InstallStatusMsg:{},InstallStatusMsg:{"DeviceId":"026913783951-{8764d21d-78d0-11e8-b75b-806e6f6e6963}","Statuses":Byte[292]},Message:{"TimeStamp":"11/20/2020 6:34:07 PM"}

 

Many Thanks

2 Answers

Order By:   Standard | Newest | Votes
Farid.S | posted this 21 November 2020

We have cloud server in version 15.0.1.1181.

Agent version is 15.0.1.182.

We already have same devices in this server which have been enrolled correctly few days ago.

In facts we tried to enroll 4 devices, 2 of them have been enrolled successfully.

Device Manufacturer is Microsoft Corporation Surface Go (Win 10).

I precise that the devices were previously enrolled in another of our SOTI cloud server (14.4.9), where an agent upgrade was planned to update automatically devices from 13.4.0.5074 to 15.0.1.182 and after that a profile including the new provision agent was installed.

It has been working correctly for almost 10 devices like this way but some of them installed correctly new agent 15.0.1.182 but if we launch SOTI agent inside these devices we can see several lines like:

13:01:10 Agent disconnected from server s10xxxxx

13:01:08 Agent connected to server s10xxx

12:58:30 Agent disconnected from server s10xxxx

12:58:26 Agent connected to server s10xxxx

 

I tried to process to all windows updates last night but I didn't have time to check if after that the device was connected to SOTI server because my colleague turned it off before moving from office.

Except TeamViewer, we have installed anything else on it so I don't think that there is something wrong with auto signed certificate.

As the devices were owned by our customer maybe they need to be on admin mode?

It seems like the user session by default isn't admin, I don't know if this could make it not working...

  • 0
  • 0
Raymond Chan | posted this 21 November 2020

What are the version and build numbers of your MobiControl server?  Is it on-premises or a  cloud instance?

 

Is it a new server instance? Or recently upgraded from a previous version/build?  Have you ever successfully enrolled AND  managed any Windows 10 devices (say at least in the last 3-6 months) on this server?

 

Is your SSL certificate self-signed or bought from a reputable CA vendor?  What are the key-length and algorithm used in the certificate?  Is it a single-domain, multi-domain or wild-card SSL certificate?

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback