writesecuresetting on Android+

writesecuresetting on Android+

Mobicontrol: 13.3

Devices: Panasonic FZ-A2

Android: 6.0.1

Tried to send both (through SOTI-script):

writesecuresetting –sys screen_brightness 200

writesecuresetting –sys screen_off_timeout 60000

But to no avail

(I used 'watchsettings on' to know the setting, this worked fine)


6 Answers

Order By:   Standard | Newest | Votes
WGKWVL_DV | posted this 18 January 2019

All thanks for your input, but the problem is actually caused by language/keyboard-settings on the device that generates the script.

When a 3th party entered/ran the script, all went fine.

As soon as I use a '0' in the value, the script does not function anymore, if run from my laptop


writesecuresetting –sys screen_brightness 200 > does not work

writesecuresetting –sys screen_brightness 211 > does work


If the 3th party provides the script (with '0') and I copy/paste it > OK

If I backspace a trailing '0' en reenter is > the script doesn't work anymore

Problem is due the PC from were the script is entered (not SOTI itself)



  • 1
  • 0
Shawn T | posted this 07 January 2019

Of course you are right Matt. I was a little overzealous with my post.

  • 0
  • 0
Matt Dermody | posted this 07 January 2019

writesecuresettings does work with Android+ (DA) as we use it quite frequently with Zebra Android devices. We definitely miss it, along with the other mentioned scripts in AEDO however. 

  • 0
  • 0
Shawn T | posted this 05 January 2019

Unfortunately the writesettings, writesecuresettings, replacetxt commands do not work on Android plus (DA) or AEDO devices. The loss of the kill_application, wipeapplication, and watchsettings when moving to AEDO is very concerning. Particularly when when trying to update applications on devices in the field. 


  • 0
  • 0
WGKWVL_DV | posted this 04 January 2019


kill_application, wipeapplication, and watchsettings al work fine on this device.

But I can't get the writesettings operational

No error though on the device when sending or in the console, but the setting on the device remains unchanged


  • 0
  • 0
Matt Dermody | posted this 21 December 2018

Many of the SOTI scripts are not supported by Android Enterprise managed devices and I don't think they've made it very clear which, if any, will be supported and when. I've been performing my own independent testing of scripting support on DA vs. AEDO devices and there are a number of key scripts not currently supported including: kill_application, wipeapplication, and watchsettings. 

  • 0
  • 0

Give us your feedback
Give us your feedback