Zebra OS-Update issue

Zebra OS-Update issue

Hey Guys,

 

I have a very specific Updateproblem with Zebra Devices. Anyway, hopefully someone can help me or got the same issue in the past.

 

We try to Update our Zebra TC20 from OS 04.14.30 Lifeguard 4 to Lifeguard 13. If I do this with adb sideload and a USB Cable everything works fine. 

We also done a few Updates remotely with Soti-Command Install_system_update and also with Zebra MX OS Update (http://techdocs.zebra.com/stagenow/3-4/csp/power/) This also worked fine on ~ 100 Devices.

But now we get an Error on most of our devices. We got captured this Errormessage:

 

Firstival we thought the OS Update File was not downloaded completly. So we done a few Tests but the Update File has the same size and MDM5-Sum. We also tested to copy the Update-File with Soti Remote Control with the same issue

So for us it seems to be some local issue of the Device. Does anyone know if there is any cache limit or something else who could deny our OS Update??? Or is there any chance to force a "clean boot" which resets all the cache of the device? If we try to apply the Update on a fresh installed Device everything works fine. Also a Factory Reset can be applied by every device (same way like the Lifeguard Update)

We also checked the File-Permission of the Update-File but it's always -rw-rw---- on working and non working devices. Further we tried to copy the File to /data/tmp/public with the same result. In any Case the Update-File has always the same Size :-( Could there be any File-Lock on the Update-File or has anyone an Idea how we can log this process to find out what happens in this situation?

 

Many thanks so far.

3 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 02 October 2019

Where are you placing the file before executing it? And how are you placing (eg Package vs. File Sync vs FTP script vs MX FileMgr)

  • 1
  • 0
Daniel | posted this 02 October 2019

Hi Matt,

 

We‘re placing the File directly under sdcard which is the local Storage of the TC20 Device. We have no physical SDCard installed.

Download of the File is realized with FTP or direct copy through Remote Control.

 

Anyway, I dont think the issue depends on the Updatefile. An example: I Download and try to apply the Update on an strongly used device will mostly generate the Error mentioned above. When I now copy the Update File from this Device to a newly installed, fresh Device I can apply the Update without any Problems. So this seems to me the error has its root on the Device, Not with the Download or the Updatefile itself 

 

Kind regards 

  • 0
  • 0
John Doe | posted this 14 October 2019

I observed that sometimes package installation and copying via remotecontrol corrupts the ZIP-Files.

I checked this with generating Hashes from the file to be copied and after it got pushed to the device via package / remote control copy.

When using FileSyncRule this did not occure for me.

I dont know if this is still an issue since we use filesyncrules for all of this when it started to happen to us.

Kind Regards John

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback